ВОЙТИ

Настройка Mikrotik и 3G/4G (USB-модемов).

Последние изменения: 19.09.2017
добавить в избранные
Для активации модема необходимо зайти в роутер через Winbox.
В случае первичной настройки процесс доступа в роутер описан в этой статье.
В случае если роутер уже настроен вы можете получить локальный доступ на роутер.
После того, как вы подключитесь к роутеру, нужно открыть раздел IP -> Firewall -> NAT
Там нужно найти правило masquerade
4b18554157bf70a46fe4a9b508f05001.pngДваждый кликните на правило masquerade, откроется окно редактирования правила, на вкладке General нужно сделать так, чтобы поле Out. Interface стало пустым. по умолчанию там указан первый порт роутера, нажав на стрелку вверх напротив поля Out. Interface добиваемся результата как на картинке:
7c56cf45a0314c8611233d01893fa4b5.pngНажимаем ОКПосле заходим в раздел System -> Scheduler
Нажимаем +, открывается окно добавления скрипта, пишем имя LTE,
Выбираем Start Time: startup и Интервал повторения : 1 минута (interval=00:01:00)
в большое поле On Event пишем следующий код:

:foreach i in=[/interface lte find ] do={:local ltename [/interface lte get [$i] name ]; /ip dhcp-client add interface=$ltename disabled=no}

Выглядеть это должно как на рисунке:
a7e056dad3961e3f9bfbdc09c8a11257.pngЖмем ОК

Скрипт добавится в планировщик, и в случае, если ваш USB-модем вставлен в роутер, в течении минуты скрипт выполнится, и у вас заработает интернет.

Таким же образом в планировщик вы можете добавить с другим именем дополнительные скрипты для работы с USB-модемами.
Перезагрузка роутера при отсутствии связи с интернетом (10 пингов до 8.8.8.8):
:local PINGCOUNT 10;
:local PINGIP "8.8.8.8";
:log info message="START PING TO $PINGIP";
:local PINGRESULT [/ping $PINGIP count=$PINGCOUNT];
:if ($PINGRESULT > 0) do={:log info message="PING TO $PINGIP OK";} else={
:log info message="PINGTEST FAIL";

/system reboot;
}

Перезагрузка питания USB при отсутствии связи с интернетом:
:local PINGCOUNT 10;
:local PINGIP "8.8.8.8";
:log info message="START PING TO $PINGIP";
:local PINGRESULT [/ping $PINGIP count=$PINGCOUNT];
:if ($PINGRESULT > 0) do={
:log info message="PING TO $PINGIP OK";
} else={
:log info message="PINGTEST FAIL";
/system routerboard usb power-reset duration=15s;
}


Список поддерживаемых модемов 3G 4G с сайта Mikrotik.
Из 3G модемов советуем Huawei E3131
из 4G МЕГАФОН M150-2 Huawei E3372

Рекомендуем предварительно обновить RouterOS до последней версии. Иначе ваш модем может не поддерживаться!